开通VIP 淘币充值 客服QQ 会员Q群 校园代理 合作伙伴
搜索
查看: 927|回复: 1

Java ssh整合出的错java.lang.NoSuchMethodError: antlr.collections.AST.get... [复制链接]

发表于 2015-4-26 11:14:50 |显示全部楼层
有可能是你的jar版本问题吧,
因为Struts自带的antlr-2.7.2.jar,比Hibernate3.3自带的antlr-2.7.6.jar的版本要低,故要删除前一个低版本的,, struts1.3 和2.1都带有antlr-2.7.2.jar ,,,下面我要把它们都清除了,,
由于myeclipse 添加的struts性能 不是放在工程lib下的,而是myeclipse自带的,,所以删除比较麻烦,,我觉得最简单的做法应该是这样:

直接在你myeclipse安装目录下的configuration\org.eclipse.osgi\bundles 下搜索antlr-2.7.2.jar ,之后搜索出来的都删除,就OK啦
关闭

站长推荐上一条 /1 下一条

发布主题 快速回复 返回列表 官方QQ群
Copyright (C) 2014-2016 taobishe.com, All rights reserved

Powered by Discuz! X3.2 淘毕设网 鲁ICP备15008547号-1
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表本站官方立场。
底部导航:关于我们|SSH毕业设计|Archiver|手机版| 淘毕设网 Inc.

快速回复 返回顶部 返回列表